Official Lords of Uberdark Forum
Bug List A.41 (Actively Updated) - Printable Version

+- Official Lords of Uberdark Forum (
+-- Forum: Lords of Uberdark (/forumdisplay.php?fid=3)
+--- Forum: Bugs/Glitches (/forumdisplay.php?fid=8)
+--- Thread: Bug List A.41 (Actively Updated) (/showthread.php?tid=444)

Pages: 1 2

Bug List A.41 (Actively Updated) - SabotageTheFool - 03-19-2012 10:57 AM

B = Bug
A = Aaron's Answers
* = Anomaly
R = Rectified

(will be updated here also)

B1 Rock Beats Scissors, Bush Beats Rock
If you throw a bush onto rock it will make a patch of dirt, mining multiples of these you can (very slowly but eventually) mine stone using a copper pick, something you can't do normally.
(Same as old: B8 Softening Stone, too;
Mining stone is not possible with the copper pick. However, this can be circumvented by building through stone with dirt. After doing so, mining the area will not only be possible, but with retrieve both your used dirt and the stone that was there.)

B2 Separated Stacks & Non Combinable Stacks.
Placed and picked up torches don't stack on the original stack of torches. When you FIRST throw a torch, if you catch it in mid air it will stack with the originals. There is no way to combine stacks of items in the inventory. If you reach over 1000 of stone, for example, and build with the larger stack, you cannot combine the stacks so you have a stack of 1000 and a smaller stack again.

B3 Torches Hard As Rock
If you place a torch on dirt, the material it transforms it to is harder than the Copper Pickaxe can actually mine, meaning if you spam an area with them you can't mine them again.

B4 No Pick Ups Underwater.
Cannot pick things up under water, you can, however, loot items that are underwater as long as you are not underwater. You will not be able to see the item through the surface of the water, however, so it is quite difficult.

B5 No use Hammer
Hammer does nothing except make a tree chopping noise when used on trees. It does not actually chop down trees but can be used as a weapon still. (Though it could well be used for Smithing later).

B6 Lost Materials
Dragging and dropping a building material out of your inventory will cause you to drop it and lose it forever, as it will fall through the world. Dropping materials does not currently drop a collectible item as all other items do...

B7 Material Jetpack Lives On!
The "stone jetpack" as it has been called still works with normal debris but not block debris due to it's new single cube placement. Stone seems to work best for some reason.

B8 Bouncy Player
Because of how player collisions work right now, falling a great distance causes you to bounce a great distance back upward.

B9 Seeing Past Existence
If you "material jet pack" high enough, you can see through the edges of the map to see the moon and sun as they rise, they'll be cut off at a point then reappear.

B10 Pressing Shift + F7 (Load Map) will do one of two things:
- If you haven't opened the inventory yet, you will enter a No-Clip style mode where all trees disappear, all items are gone in your inventory, this will actually load any saved map however, now after a short time (or if you collide with anything solid) you will hear the digging noise and a black piece of debris will appear on the screen and you won't be able to move.
- If you HAVE opened the inventory, the game will crash.

B11 Continued Switch
When switching between Tools and Materials with Q and E you won't return to your last used Tool or Material, but the next in the switching list, so you have to cycle back through again.

B12 Ocean Floor Texture Change
Attaching a Torch to the ocean floor where the Crystal Rock section starts, the whole ocean floor turns to the Crystal Rock texture, flattened.

B13 Stone + Tree = Black
You can build into a tree with stone (basically no clipping the stone inside the tree) and when you completely surround the base of the tree with stone (and now a little higher), the entire tree turns black. Image

B14 What? No Superbomb?
If you drag and drop your Bombs from your inventory, it will drop all of them at once, but only as one bomb which will then explode as one bomb. Same for Bushes, Shrooms and Torches, though Bars and Boards keep their item count.

B15 I Can Jump Through Trees Big Grin
If you jump into a tree, above the bottom of the trunk you will no clip through.

B16 Building.. Old School Style
If in building you hold left click then swing your mouse up quickly you'll start building mid air.

B17 No captials
If you use a capital X when setting the Screen Resolution, it will come out a wrong size and seems stretched and zoomed and unplayable (very trippy).

B18 Cant... Move....
If you make another window active while Lords of Uberdark is loading your mouse with be confined to the area that the Lords of Uberdark window has loaded as, it keeps re-centering your mouse until you're in game, usually needing to use the likes of Alt+Tab to get into it.

B19 One for luck...
If you place of a material you'll hold one unusable piece.

R1 Doubling Up
You will now mine the same amount of a material that you place instead of much more.

R2 Horizon Off
Now with the new Horizon display-a-majig, the horizon is correctly shown by the on screen representation.

This (most annoying) bug no longer crashes the game ^_^

*1 Two Trees One Axe
If you stand in front of two trees, very close together, it is possible to chop both at the same time with one axe swing. This happens too for two Zombis, cleaving through both at once!

*2 Trees collapse in on themselves like a supernova until there is nothing, not reducing to a Stump or the like.

*3 The shield is just a model at the minute (Or so it seems) as it blocks no damage.

*4 (Windows) If you move the Lords of Uberdark window while it is loading it was come up as "Not Responding" until it is loading.

*5 You still move if you're typing in Steam Chat when running it via steam (though this is much less destructive now with less hotkeys).

RE: Bug List A.41 (Actively Updated) - Ben - 03-19-2012 12:44 PM

B18 doesn't just apply to windows, it's the same on Linux including the alt+tab thing.

RE: Bug List A.41 (Actively Updated) - SabotageTheFool - 03-19-2012 02:30 PM

Wasn't sure how other systems worked or interacted, thanks for clearing that up.

RE: Bug List A.41 (Actively Updated) - Ben - 03-19-2012 02:48 PM

As for *1, that's because (as far as I can tell) hitting actually uses collision to decide what it hits, rather than just what you're pointing like in MC, you can see the collision spheres by holding F1 during play Big Grin I think that's how it works anyway Tongue

RE: Bug List A.41 (Actively Updated) - DeamonHunter - 03-20-2012 04:04 AM

First bug I've seen so far is, when looking downwards and you press s instead of going backwards, you jump and bounce upwards from your position. Annoying when your trying to build while looking downwards.

RE: Bug List A.41 (Actively Updated) - SabotageTheFool - 03-20-2012 08:17 AM

I should of had that in anomolies I think o.o

It's the super jump Tongue If you jump at the same time you go higher, same as looking up and pressing W and jumping Wink

RE: Bug List A.41 (Actively Updated) - Zetsubou - 03-23-2012 10:38 PM

I have recently donated to the game and received the most recent version of the game and i was wondering if there was any way at all to save a world. Being unable to save has severely hindered me from enjoying the game.

RE: Bug List A.41 (Actively Updated) - Ben - 03-23-2012 10:44 PM

They almost have saving working, the next release shouldn't be far off, and should have it implemented. For now we can export a world with F7 and import with shift+F7, but it doesn't really work, and might not be compatible with the new save system in the next update.

Welcome to the forums by the way Big Grin

RE: Bug List A.41 (Actively Updated) - Zetsubou - 03-24-2012 12:11 PM

I've tried the import export system that is currently implemented but it sadly does not work for me it loads the world but leaves me in a no-clip mode is there a way to fix this or is my best bet to just wait for the new updated save system?

RE: Bug List A.41 (Actively Updated) - Ben - 03-24-2012 12:15 PM

(03-24-2012 12:11 PM)Zetsubou Wrote:  I've tried the import export system that is currently implemented but it sadly does not work for me it loads the world but leaves me in a no-clip mode is there a way to fix this or is my best bet to just wait for the new updated save system?

Nope, but as I said the save system is coming soon according to the devs.